This project is read-only.

IIS6 and LiveWriter?

Mar 23, 2009 at 9:47 PM
Hey guys,  I keep getting a 401 with IIS6 trying to get my service.atomsvc.. In fact if I hit it from a browser I can't get access to it until after login using forms authentication (the standard HTTP authentication fails repeatedly).. Is there a workaround or IIS6 setting I'm missing? Unfortunately upgrading to IIS7 is not really an option for this specific effort.

Thanks
Josh
Mar 23, 2009 at 10:13 PM
Edited Mar 23, 2009 at 10:15 PM
The service.atomsvc document is a secure resource.  Depending on your configuration, you'll need to use WSSE, Basic, or Forms Authentication to access it.  You can check fiddler to see what is happening by looking at the auth headers.  Likely there is some other Authentication module interferring as this has happened to me before.  Try to disable the built-in windows, digest, and basic auth modules.

Also check the log files in App_Data folder for more clues.  

Finally, you could also turn on anonymous access through the rolematrix if you don't need the security:

add the below text to the <service> element of the service document.

<svc:roleMatrix><svc:roleAction name='GetServiceDoc' admin='True' author='True' contrib='True' user='True' anon='True'/></svc:roleMatrix>

Mar 23, 2009 at 10:32 PM
Actually turning off IIS authentication did the trick :-)... Thanks

Josh
Mar 24, 2009 at 3:27 AM
Hmm...

I am getting a similar problem, but in IIS7.  I have created a basic copy of the AtomSiteBinary, called it AtomSiteDemo.

I can log on and make changes within the site, but when trying to hook up LiveWriter I get a 404 or 401 error depending upon whether I enable Windows Auth.

I have Live Writer set to :  http://localhost/AtomSiteDemo as the web address, to try to edit on my local box.

I have also tried http://localhost/AtomSiteDemo/default.aspx    neither works...

Also tried adjusting my HOSTS file to lcl.atomdemo.com and adding the site as a new "site" in IIS7.  Still no go.

Logging in with admin account.

Any direction here would be appreciated.

Thanks,
Tom
tlatourelle@hotmail.com
Mar 24, 2009 at 5:09 AM
Please add a slash onto the end of the base address in your service.config file.  I'll fix this bug in svn tomorrow.  Thanks,

 xml:base="http://localhost/AtomSiteDemo/">
Mar 24, 2009 at 5:59 AM

That worked.  I am surprised you were able to track that down.

It also explains why it did not work when I re-set the site in my hosts file to lcl.atomdemo.com, because I did not edit this line.

As a follow-up, is it possible to add multiple uri entries for this site in this xml file to account for multiple points of entry?

Thanks,

Tom

From: jarrettv [mailto:notifications@codeplex.com]
Sent: Monday, March 23, 2009 11:09 PM
To: tlatourelle@hotmail.com
Subject: Re: IIS6 and LiveWriter? [blogsvc:51030]

From: jarrettv

Please add a slash onto the end of the base address in your service.config file. I'll fix this bug in svn tomorrow. Thanks,

xml:base="http://localhost/AtomSiteDemo/">

Read the full discussion online.

To add a post to this discussion, reply to this email (blogsvc@discussions.codeplex.com)

To start a new discussion for this project, email blogsvc@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.278 / Virus Database: 270.11.25/2019 - Release Date: 03/23/09 18:51:00